Written By: |
Mark Christensen |
---|---|
Manufacturer: |
Avaya |
Product: |
Communication Manager |
Version: |
All versions |
Patch Information: |
N/A |
Ticket Number(s): |
Description:
Alarmtraq or other alarm reporting system reported a avCmAlmSysLinkMinor trap
Related Articles:
Refer to the document "Avaya Aura® Communication Manager Alarms, Events, and Logs Reference" for more information.
Refer also to "Switch Node Interfaces" for a short description of the same.
Problem Clarification:
An avCmAlmSysLinkMinor trap is reported as the result of a SYS-LINK alarm in Communication Manager.
Cause:
There can be several causes of a SYS-LINK alarm, including problems with:
- A remote socket control link (RSCL) terminating on CLAN boards (TN799)
- Expansion interfaces (TN570)
- Maintenance Board Link terminating at an IPSI board (TN2312) that provides Environmental maintenance for a G650 rack mounted cabinet
- ISDN-PRI D-channel terminating on a DS1 board
- Media Processor Control Channel. This link carries media processor signaling
System links are packet links that originate at the Packet Interface board and traverse various hardware components to specific endpoints. The hardware components involved on the forward and reverse routes can be different, depending upon the configuration and switch administration. The command "status sys-link" is useful in troubleshooting system link issues.
System link problems
The state of a system link is dependent on the state of the various hardware components that it travels over. To resolve any problems associated with a system link, use the following procedure.
The switch maintains a list of hardware components over which the link travels, called the hardware path (see the "status sys-link", below). There are two hardware paths: the current hardware path and the faulted hardware path for each of the system links. The current hardware path is present only for those links that are currently up. When a link is down, the current hardware path is empty. The faulted hardware path is always present once the link has gone down, and is not cleared when the link subsequently recovers. The faulted path preserves the path that the link traversed when it last went down. The time at which the faulted path was last recorded is preserved and is accessible through "status sys-link <location>" and "list sys-link." Therefore, the focus of attention for problems which do not involve a link that is down is the current hardware path. If the link is down, faulted hardware path is the focus of attention.
Note: You can run the command "test sys-link <board location> in versions later than R015.
Here is an example using the command "status sys-link <board location>":
status sys-link 06A01 Page 1 of 2
Location: 06A0101 Type/dlci: EAL Alarms: none
Current Path: present State: up Time Up: 06/21/2023 23:19
Faulted Path: default Last Fault: 06/21/2023 23:18
Current Hardware Path
Maintenance Maintenance
Location Name Alarms Location Name Alarms
02A PKT-INT none
PN 03 PKT-BUS none
02A01 EXP-INTF none
3 A-PNC FIBER-LK none
01E03 SNI-BD none
01E05 SNI-BD none
7 A-PNC FIBER-LK none
06A01 EXP-INTF none
The example above is from a system with an SNI carrier in 1E.
The system link status in the example shows a path starting with an IPSI board (TN2312, which connects to the customer's network) in slot 2A00. The TN570 Expansion Interface (EXP-INTF) at 2A01 is connected via fiber cable to an TN573 SNI board in 1E03, and also administered with a TN573 in 1E05. Note: when you see a notation like "3 A-PNC", it is referring to a fiber link (fiber link 3).
From there, a connection is made via fiber to the far-end cabinet with TN570 Expansion Interface in 6A01, and is referred to as fiber-link 7 (see "display fiber-link 7", below).
With G650 cabinets, there are no SNI boards or SNI carriers.
You can run the command "list fiber-link" or "display fiber-link <fiber link #>" to see how the endpoints are connected.
Here is an example of a fiber link:
display fiber-link 7
FIBER LINK ADMINISTRATION
Fiber Link #: 7
Is one endpoint remoted via DS1 Converter Complex? no
ENDPOINT-1 ENDPOINT-2
(A-PNC) (A-PNC)
Board Location: 01E05 Board Location: 06A01
Board Type: sni Board Type: ei
Fiber Translation: Converter?
Type of Transceivers:
The Switch Node Interface board at 01E05 connects to the Expansion Interface at 06A01 via fiber.
Solution:
Refer to the "Cause" section, above.
Look for alarms along the faulted path. Run the command "display errors", and enter in the board location ("Board Number:"). Refer to the document "Avaya Aura® Communication Manager Alarms, Events, and Logs Reference". Replace any boards that indicate an "on board" error.
Sometimes, a fiber connection between boards may cause a problem. Run the command "list fiber-link" or "display fiber-link <fiber link #>" to see how endpoints are connected. The fibers are interconnected using a fiber interface built on an amphenol connector plugged into the back of the carrier, and the fiber is connected to that interface on each side of the fiber link.
Manufacturer Release notes:
Disclaimer: intlx Solutions Knowledge Base
The information contained in this knowledge base ("Content") is provided for informational purposes only and is intended to be a general resource. intlx Solutions does not guarantee the accuracy, completeness, or timeliness of the Content.
Use at Your Own Risk: By accessing and using the Content, you agree that you do so at your own risk. intlx Solutions assumes no responsibility for any errors or omissions in the Content, nor for any damages or losses you may suffer arising out of or related to the use of the Content.
Current Customers: If you are a current intlx Solutions customer and have questions or require further clarification on any information presented here, please do not hesitate to contact our support team directly. They are available to assist you and ensure you have the most up-to-date information specific to your needs.
Not a Customer? If you are not currently an intlx Solutions customer but are interested in learning more about our solutions and how we can help your business, please click here. We look forward to the opportunity to discuss your needs and explore how a partnership with intlx Solutions can benefit you.
Thank you for your understanding.
This article contains data that is aimed at helping fix an issue with a product. Please use this information at your own risk as intlx Solutions is not responsible for actions taken by the steps or procedures shown in these articles.