Written By: |
Mark Christensen |
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Manufacturer: |
Avaya |
Product: |
Communication Manager using G650 cabinets |
Version: |
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Patch Information: |
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Ticket Number(s): |
Description:
This article describes PKT-INT alarms, including avCmAlmPktIntMinor traps, and how to troubleshoot them.
Related Articles and Documentation:
Refer to Avaya Aura® Communication Manager Alarms, Events, and Logs Reference. Also refer to: https://support.avaya.com/public/index?page=content&id=SOLN275364&viewlocale=en_US
Problem Clarification:
A PKT-INT major or minor alarm has occurred.
The packet interface resides on the TN2312 IP Server Interface (IPSI) circuit pack. This circuit pack connects to customer network switches and from there to Communication Manager server(s).
This circuit pack also supplies:
- tone clock (maintenance object TONE-BD) functionality, providing tone generation, tone detection, call classification, clock generation, and synchronization
- connectivity to the customer's network and Communication Manager servers (via ethernet switches)
- TDM bus interface (Archangel)
- an ethernet interface for a laptop
A packet interface failure prevents call setup and tear-down from phones and trunks connected to port networks. It also affects the function of CLAN, VAL and IPMEDPRO (TN2302 and TN2602) circuit packs.
If an active IPSI causes a major alarm, and there is a duplicated IPSI in the same port network with a state of health that allows for an interchange, a spontaneous interchange will occur.
Here is an example of connectivity from the Communication Manager servers (Server A and B). It's called the "High-Reliability Configuration." Notice how the Communication Manager servers have duplicated connections to Control Networks A and B and the port networks have duplicated IPSIs:
IPSIs are installed in G650 cabinets, generally in carriers A and B. However, in cabinets administered with multiple port networks, they could be located in other carriers as well. IPSIs do not have to be duplicated.
Cause:
PKT-INT alarms can have a number of causes, including network connectivity issues. Check and analyze IPSI-related issues, such as PKT-INT, TDM-CLK, SYNC and TONE-BD alarms that occur around the same general timeframe. Also look for CAB-PFL, PS-RGEN and CAB-MTCE alarms within the same time period. This could indicate a power-related problem.
Troubleshooting and Solution:
The following is a snippet of a list of IPSIs and their associated IP addresses:
list ipserver-interface Page 1
IP SERVER INTERFACE INFORMATION
Port Pri/ Primary/ Primary/ Primary/ State Of
Ntwk Sec Secondary Secondary Secondary Serv Control Health
Num Bd Loc IP Address. Host Name DHCP ID State State C P E G
---- ------ --------------- ---------------- --------- ----- ------- -------
8 8A01 12.34.176.20 12.34.176.20 ipsi-A08a IN actv-aa 0.0.0.0
8B01 12.34.176.148 12.34.176.148 ipsi-A08b IN standby 0.0.0.0
11 11A01 12.34.175.20 12.34.175.20 ipsi-A11a IN actv-aa 0.0.0.0
11B01 12.34.175.148 12.34.175.148 ipsi-A11b IN standby 0.0.0.0
The "Serv State" tells you if the IPSI is "IN" or "OUT" of service.
The "State Of Health" is helpful to determine further troubleshooting. The example shows a good state of health. These are binary values pointing to the following functions of the IPSI board:
C = Clock
P = Packet Interface
E = Expansion Archangel Link
G = Tone Generation
PKT-INT error log entries and recommended actions
Refer to the notes in Avaya Aura® Communication Manager Alarms, Events, and Logs Reference under "PKT-INT error log entries and recommended actions." On-board errors usually indicate a bad board.
You can run the command "status packet-interface" to see the status of a packet interface. Here's an example:
status packet-interface 11
PACKET INTERFACE STATUS
Location: 11A
Service State: in-service
Total Links: 4
Active Links: 4
Failed Links: 0
Location: 11B
Service State: out-of-service
Total Links: 0
Active Links: 0
Failed Links: 0
If you run the "reset packet-interface 11B" command and see:
reset packet-interface 11B
TEST RESULTS
Port Mtce Name Alt. Name Test No. Result Error Code
11B PKT-INT 889 FAIL 266
The packet interface module on the IPSI circuit pack detected a fatal failure. This error is very serious. Maintenance software immediately escalates testing to the Packet Interface Reset Test (#889). This error is likely caused by network connectivity loss between the Communication Manager server and the IPSI where the packet interface module resides.
If test 889 fails, dispatch a technician to check connectivity between the IPSI circuit pack and the network switch it is connected to. If connectivity is ok, replace the IPSI circuit pack.
Notes about the Packet Interface Reset Test (#889)
The reset action initializes the packet interface firmware on the IPSI circuit pack and runs a comprehensive set of diagnostic tests.
The demand reset action aborts if the specified IPSI circuit pack’s packet interface module is in the active in-service state.
An IPSI circuit pack’s packet interface module is put in the out-of-service state automatically if it resets 3 times by background maintenance within the last 15 minutes, independent of the results of the reset action.
If the packet interface module is on the standby IPSI (Duplicated Server Fiber-PNC: and this is a high- or critical-reliability system), the demand reset action runs, independent of the service state.
Manufacturer Release notes:
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