Written By: |
Jason Harwood |
---|---|
Manufacturer: |
Salesforce |
Product: |
CRM Connector |
Version: |
N/A |
Patch Information: |
N/A |
Ticket Number(s): |
N/A |
Description: This article will provide a possible solution for when the Salesforce CRM Connector locks up.
Problem Clarification:
Upon reviewing the logs, it appears that the CRM connector ran out of memory.
Cause:
CRM Connector ran out of memory.
Solution:
In this example the system seems to have logged the issue on October 17th at 8:12PM. File in /root/logs.txt showing an excerpt from /var/log/messages before the file overwrites.
Oct 17 18:12:31 CRMSF301 docker-compose: #033[33miec-app_1 |#033[00
m Caused by: java.lang.OutOfMemoryError: unable to create new native thread
[root@CRMSF301 log]# grep memory cron
Oct 17 18:01:01 CRMSF301 crond[850]: (CRON) CAN'T FORK (do_command): Cannot allocate memory
Reboot the connector to fix.
Manufacturer Release notes:
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