Written By: |
Mark Christensen |
|---|---|
Manufacturer: |
Avaya |
Product: |
Communication Manager and Media Gateways |
Version: |
All |
Patch Information: |
|
Ticket Number(s): |
62182 |
Description:
This article describes how to troubleshoot media gateway synchronization faults.
Related Articles:
Problem Clarification:
One or more media gateways send the SNMP trap cmgSyncSignalFault, indicating a problem with a sync source. A sync source can refer to a clocking source derived from either a local clock on a media gateway, or in the case of Clock Sync over IP (CSoIP), a DS1 board administered in a media gateway. This clock determines timing on the TDM bus of the media gateway. It is not related to a clocking signal derived from a Network Time Protocol (NTP) server.
Cause:
To determine what causes a synchronization problem, the following procedure should be used:
- In Communication Manager, run the command "
status synchronization" and look for the media gateway that the ticket is referring to. Determine the "Source Physical Location" of the DS1 board. Run the command "test board<board_location>" and verify that tests 138 through 146 pass. If one of these tests fail, refer to the the document "Avaya Communication Manager Alarms Events and Logs Reference" to troubleshoot the error. If the tests persistently fail for more than a few minutes, you may need to contact the customer to determine the vendor, and work with them. - If several media gateways are having a problem with the same synchronization signal and occur frequently over time, and the "
Source Physical Location" of the DS1 board passes board tests, this may be an indication of a network problem. Monitor for a few minutes to see if the issue persists or goes away. -
If only one media gateway is reported to have the synchronization signal fault, log into the media gateway, and run the command "
show sync timing":AcmeSprocketsG430-080(super)# show sync timing SYNCHRONIZATION CONTROL: --- Remote --- SOURCE MM or VoIP STATUS FAILURE --------- ------------------- ----------------------- --------------- Primary VoIP Active None Secondary Not Configured Local v0 Standby None Active Source: VoIP Sync Source Switching: EnabledIf the primary source shows "
VoIP", and "Active" (under "STATUS"), and "None" (under "FAILURE"), then the problem has resolved itself. If "Loss" is displayed (under "FAILURE"), then the primary synchronization source signal has been compared to the local clock's signal from the media gateway and the local clock is determined to be a more reliable source. If this is the case, theSOURCELocalwill display a status of "Active".
Solution:
Clock synchronization is important when the customer uses H.320 devices, or has fax machines or modems connected to media gateways, because these derive their timing via the TDM bus on the gateway through the gateway's local clock, or in the case with Clock Sync over IP, the administered timing source, which could be a BRI or DS1 board (connected to a service provider).
The Avaya Aura Communication Manager algorithm changes distribution dynamically as the media gateway changes timing reference. The timing reference change could be from administrative action or from loss of signal error switching.
To address an issue with a sync signal fault, start by running the command "status synchronization" and look for the media gateway listed in the ticket. Some examples follow:
status synchronization Page 1
SYNCHRONIZATION STATUS
Source Source Excessive
Stratum Maintenance Physical Switching Reference
Location Level Name Location Capability Switching
MG 01 4 IP-SYNC 002V2 Enabled No
MG 02 4 MG-DS1 002V2 Enabled No
MG 03 4 MG-DS1 003V3 Enabled No
MG 07 4 MG-DS1 007V2 Enabled No
MG 08 4 MG-DS1 008V2 Enabled No
...
MG 35 4 LOCAL-CLK 035V0 Enabled No
...
MG 80 4 IP-SYNC 002V2 Enabled NoIP-SYNC indicates the media gateway (The media gateway form is administered "Use for IP Sync?" set to "y") derives its clock from a master media gateway determined by Communication Manager software. Communication Manager internal software determines master, tandem and slave media gateways.
Switching Capability indicates that the reference clock can be switched to another DS1 board in the media gateway defined by the form "display synchronization media-gateway <mediagatewaynum>". If the clock frequency drifts far enough compared to the media gateway internal clock reference, Excessive Reference Switching is taking place.
If "Use for IP Sync?" is set to "n" on "display media-gateway <mediagatewaynum>", and there is no DS1 or BRI board, then the media gateway's local reference clock will be used to determine timing.
Access the media gateway and run the command "show sync timing". Refer to step 3 in "Cause".
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