Written By: |
Kenny Pearl |
---|---|
Manufacturer: |
Avaya |
Product: |
G430, G450, Communication Manager |
Version: |
All versions |
Patch Information: |
|
Ticket Number(s): |
3609 |
Description:
Alarms are being received from Communication Manager with the following string in the alarm "avCmAlmServMssMgMinor" with the alarm text of "A Minor MSS-MG Server alarm has been generated by the system." The alarm does not appear to be service impacting and it usually is not.
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Problem Clarification:
The alerts are actually coming from a media gateway that is registered to Communication Manager (CM) and is sending a trap to CM, that is relayed to intlx Solutions and to any configured NMS server.
Cause:
This issue is related to a device that is making unauthorized SNMP requests to the media gateway and the media gateway reports it as a denial of service alarm.
Solution:
In order to resolve this issue we either need to update the device making the unauthorized SNMP requests with the correct SNMP information for the gateways or configure the device to stop making requests. In order to find out the IP address of the device making the request we can use the following command(s).
In order to determine the IP address of the host responsible for generating these alarms login to CM and get to a Linux Shell Session. Once at a Linux shell session run the following command.
user@cm1> sudo logc today | grep Mss > mssalarms.txt
user@cm1> cat mssalarms.txt
172.134.0.39(via UDP: [172.134.0.39]:161->[172.10.99.10]:162) TRAP, SNMP v1, commuu
nity NoVision#012#011avMssNotifications Enterprise Specific Trap (avMSSDenialOff
Service) Uptime: 19 days, 11:25:44.48#012#011avMSSVarbindsDoSType.0 = INTEGER: aa
vMSSunAuthenticatedAccess(13)#011avMSSVarbindsSrcAddr.0 = IpAddress: 172.100.105.25
5#011avMSSVarbindsDstAddr.0 = IpAddress: 0.0.0.0#011avMSSVarbindsDstPort.0 = INTT
EGER: 22#011avMSSVarbindsCount.0 = Counter64: 1#011avMSSVarbindsIpProtocol.0 = II
NTEGER: 6#011ifIndex = INTEGER: 0#011ifName = STRING: #011avMSSVarbindsSrcMACAddd
r.0 = STRING: 0:0:0:0:0:0
20240618:081333000:591938:lxsys:MED:cm1 snmptrapd[2401]: 2024-06-18 08:13:33
172.134.0.29(via UDP: [172.134.0.29]:161->[172.10.99.10]:162) TRAP, SNMP v1, commuu
nity NoVision#012#011avMssNotifications Enterprise Specific Trap (avMSSDenialOff
Service) Uptime: 19 days, 11:25:48.83#012#011avMSSVarbindsDoSType.0 = INTEGER: aa
vMSSunAuthenticatedAccess(13)#011avMSSVarbindsSrcAddr.0 = IpAddress: 172.100.105.25
5#011avMSSVarbindsDstAddr.0 = IpAddress: 0.0.0.0#011avMSSVarbindsDstPort.0 = INTT
EGER: 22#011avMSSVarbindsCount.0 = Counter64: 1#011avMSSVarbindsIpProtocol.0 = II
NTEGER: 6#011ifIndex = INTEGER: 0#011ifName = STRING: #011avMSSVarbindsSrcMACAddd
r.0 = STRING: 0:0:0:0:0:0
This will create a file for you containing any alarms that related to the MSS notifications that are received by CM. The output is long and does not format well so we find it best to dump it to a file.
Using your favorite text editor take a look at your file and you will see data similar to the following.
In our example we had to work with our customer and ask what IP address 172.100.105.25 was and it was an old NMS server that was monitoring some of the Avaya gear that had outdated SNMP community information in its configuration.
Manufacturer Release notes: n/a
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