DESCRIPTION
When attempting to start the snmp daemon from the AVP (ESXI) web interface an error message pops up saying that the start of the daemon failed.
PRODUCTS
Avaya Virtual Platform (AVP) (Now ASP)
APPLICABLE SOFTWARE RELEASES
All
REALTED ARTICLES
RELATED KEYWORDS
snmp, failed, esxi, avp, monitoring
PROBLEM CLARIFICATION
When attempting to use the AVP/ESXI console to start the snmpd process a failure message is sent to the web display.
CAUSE
The issue is caused by a corrupt snmp.xml file on the VMware host.
SOLUTION
First we need to enable SSH to the VMware host so we can login to the host using an SSH command line.
From the web browser connected to the AVP navigate to the following area of the web page as shown in the image below.
Click "Enable Secure Shell (SSH)"
Once it is enable login to the server using SSH, a root or admin level account is required.
-
make a backup of the original XML file by running the command cp/etc/vmware/snmp.xml ~/snmp.xml.orig
-
Next run the command vi /etc/vmware/snmp.xml once in vi hit dd to delete any lines of text in the file
-
Once the file is empty hit the i key to enter insert mode and paste the following contents from the below text box into your file
<?xml version='1.0' encoding='ISO-8859-1'?>
<config>
<snmpSettings>
<enable>true</enable>
<port>161</port>
<syscontact></syscontact>
<syslocation></syslocation>
<EnvEventSource>indications</EnvEventSource>
<communities>public</communities>
<loglevel>info</loglevel>
<authProtocol></authProtocol>
<privProtocol></privProtocol>
</snmpSettings>
</config> - Hit escape to leave insert mode in vi, if you need to modify the snmp community string go ahead and navigate using vi to the section of the file shown in green and delete the word public and change it to whatever community string you need it to be for the customer.
- Hit :wq on your keyboard to write and quit the file.
- Return to the web page and start the SNMP service again.
- You can now see that the SNMP daemon is running on the AVP/ESXI web page
- The last item we want to ensure is to right click on the SNMP service in the web interface and ensure that the policy for this service is set to start and stop the daemon with the host.
- Change to "Start and stop with host"
Disclaimer: intlx Solutions Knowledge Base
The information contained in this knowledge base ("Content") is provided for informational purposes only and is intended to be a general resource. intlx Solutions does not guarantee the accuracy, completeness, or timeliness of the Content.
Use at Your Own Risk: By accessing and using the Content, you agree that you do so at your own risk. intlx Solutions assumes no responsibility for any errors or omissions in the Content, nor for any damages or losses you may suffer arising out of or related to the use of the Content.
Current Customers: If you are a current intlx Solutions customer and have questions or require further clarification on any information presented here, please do not hesitate to contact our support team directly. They are available to assist you and ensure you have the most up-to-date information specific to your needs.
Not a Customer? If you are not currently an intlx Solutions customer but are interested in learning more about our solutions and how we can help your business, please click here. We look forward to the opportunity to discuss your needs and explore how a partnership with intlx Solutions can benefit you.
Thank you for your understanding.